站內搜索  

哈爾濱百姓網首頁 | 操作系統 | 軟件應用 | 平面設計 | 程序開發 | 硬件維護 | 網絡安全
 您的位置: 哈爾濱百姓網 > 電腦網絡 > 硬件維護 > 閱讀文章:CISCO 2811 路由器配置命令全集
CISCO 2811 路由器配置命令全集
2010-3-1 17:15:58 哈爾濱百姓網 來源:轉載 瀏覽 次 【 】【打印】【關閉

命令狀態
1. router>
路由器處于用戶命令狀態,這時用戶可以看路由器的連接狀態,訪問其它網絡和主機,但不能看到和更改路由器的設置內容。
2. router#
在router>提示符下鍵入enable,路由器進入特權命令狀態router#,這時不但可以執行所有的用戶命令,還可以看到和更改路由器的設置內容。
3. router(config)#
在router#提示符下鍵入configure terminal,出現提示符router(config)#,此時路由器處于全局設置狀態,這時可以設置路由器的全局參數。
4. router(config-if)#; router(config-line)#; router(config-router)#;…
路由器處于局部設置狀態,這時可以設置路由器某個局部的參數。
5. >
路由器處于RXBOOT狀態,在開機后60秒內按ctrl-break可進入此狀態,這時路由器不能完成正常的功能,只能進行軟件升級和手工引導。
6. 設置對話狀態
這是一臺新路由器開機時自動進入的狀態,在特權命令狀態使用SETUP命令也可進入此狀態,這時可通過對話方式對路由器進行設置。

三、設置對話過程
1. 顯示提示信息
2. 全局參數的設置
3. 接口參數的設置
4. 顯示結果
利用設置對話過程可以避免手工輸入命令的煩瑣,但它還不能完全代替手工設置,一些特殊的設置還必須通過手工輸入的方式完成。
進入設置對話過程后,路由器首先會顯示一些提示信息:
--- System Configuration Dialog ---
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
這是告訴你在設置對話過程中的任何地方都可以鍵入“?”得到系統的幫助,按ctrl-c可以退出設置過程,缺省設置將顯示在‘[]’中。然后路由器會問是否進入設置對話:
Would you like to enter the initial configuration dialog? [yes]:
如果按y或回車,路由器就會進入設置對話過程。首先你可以看到各端口當前的狀況:
First, would you like to see the current interface summary? [yes]:
Any interface listed with OK? value "NO" does not have a valid configuration
Interface IP-Address OK? Method Status Protocol
Ethernet0 unassigned NO unset up up
Serial0 unassigned NO unset up up
……… ……… … …… … …
然后,路由器就開始全局參數的設置:
Configuring global parameters:
1.設置路由器名:
Enter host name [Router]:
2.設置進入特權狀態的密文(secret),此密文在設置以后不會以明文方式顯示:
The enable secret is a one-way cryptographic secret used
instead of the enable password when it exists.
Enter enable secret: cisco
3.設置進入特權狀態的密碼(password),此密碼只在沒有密文時起作用,并且在設置以后會以明文方式顯示:
The enable password is used when there is no enable secret
and when using older software and some boot images.
Enter enable password: pass
4.設置虛擬終端訪問時的密碼:
Enter virtual terminal password: cisco
5.詢問是否要設置路由器支持的各種網絡協議:
Configure SNMP Network Management? [yes]:
Configure DECnet? [no]:
Configure AppleTalk? [no]:
Configure IPX? [no]:
Configure IP? [yes]:
Configure IGRP routing? [yes]:
Configure RIP routing? [no]:
………
6.如果配置的是撥號訪問服務器,系統還會設置異步口的參數:
Configure Async lines? [yes]:
1) 設置線路的最高速度:
Async line speed [9600]:
2) 是否使用硬件流控:
Configure for HW flow control? [yes]:
3) 是否設置modem:
Configure for modems? [yes/no]: yes
4) 是否使用默認的modem命令:
Configure for default chat script? [yes]:
5) 是否設置異步口的PPP參數:
Configure for Dial-in IP SLIP/PPP access? [no]: yes
6) 是否使用動態IP地址:
Configure for Dynamic IP addresses? [yes]:
7) 是否使用缺省IP地址:
Configure Default IP addresses? [no]: yes
是否使用TCP頭壓縮:
Configure for TCP Header Compression? [yes]:
9) 是否在異步口上使用路由表更新:
Configure for routing updates on async links? [no]: y
10) 是否設置異步口上的其它協議。
接下來,系統會對每個接口進行參數的設置。
1.Configuring interface Ethernet0:
1) 是否使用此接口:
Is this interface in use? [yes]:
2) 是否設置此接口的IP參數:
Configure IP on this interface? [yes]:
3) 設置接口的IP地址:
IP address for this interface: 192.168.162.2
4) 設置接口的IP子網掩碼:
Number of bits in subnet field [0]:
Class C network is 192.168.162.0, 0 subnet bits; mask is /24
在設置完所有接口的參數后,系統會把整個設置對話過程的結果顯示出來:
The following configuration command script was created:
hostname Router
enable secret 5 $1$W5Oh$p6J7tIgRMBOIKVXVG53Uh1
enable password pass
…………
請注意在enable secret后面顯示的是亂碼,而enable password后面顯示的是設置的內容。
顯示結束后,系統會問是否使用這個設置:
Use this configuration? [yes/no]: yes
如果回答yes,系統就會把設置的結果存入路由器的NVRAM中,然后結束設置對話過程,使路由器開始正常的工作。
返回目錄


四、常用命令
1. 幫助
在IOS操作中,無論任何狀態和位置,都可以鍵入“?”得到系統的幫助。
2. 改變命令狀態
任務 命令
進入特權命令狀態 enable
退出特權命令狀態 disable
進入設置對話狀態 setup
進入全局設置狀態 config terminal
退出全局設置狀態 end
進入端口設置狀態 interface type slot/number
進入子端口設置狀態 interface type number.subinterface [point-to-point | multipoint]
進入線路設置狀態 line type slot/number
進入路由設置狀態 router protocol
退出局部設置狀態 exit
3. 顯示命令
任務 命令
查看版本及引導信息 show version
查看運行設置 show running-config
查看開機設置 show startup-config
顯示端口信息 show interface type slot/number
顯示路由信息 show ip router
4. 拷貝命令
用于IOS及CONFIG的備份和升級

5. 網絡命令
任務 命令
登錄遠程主機 telnet hostname|IP address
網絡偵測 ping hostname|IP address
路由跟蹤 trace hostname|IP address

6. 基本設置命令
任務 命令
全局設置 config terminal
設置訪問用戶及密碼 username username password password
設置特權密碼 enable secret password
設置路由器名 hostname name
設置靜態路由 ip route destination subnet-mask next-hop
啟動IP路由 ip routing
啟動IPX路由 ipx routing
端口設置 interface type slot/number
設置IP地址 ip address address subnet-mask
設置IPX網絡 ipx network network
激活端口 no shutdown
物理線路設置 line type number
啟動登錄進程 login [local|tacacs server]
設置登錄密碼 password password


五、配置IP尋址

1. IP地址分類
IP地址分為網絡地址和主機地址二個部分,A類地址前8位為網絡地址,后24位為主機地址,B類地址16位為網絡地址,后16位為主機地址,C類地址前24位為網絡地址,后8位為主機地址,網絡地址范圍如下表所示:
種類 網絡地址范圍
A 1.0.0.0 到126.0.0.0有效 0.0.0.0 和127.0.0.0保留
B 128.1.0.0到191.254.0.0有效 128.0.0.0和191.255.0.0保留
C 192.0.1.0 到223.255.254.0有效 192.0.0.0和223.255.255.0保留
D 224.0.0.0到239.255.255.255用于多點廣播
E 240.0.0.0到255.255.255.254保留 255.255.255.255用于廣播
2. 分配接口IP地址
任務 命令
接口設置 interface type slot/number
為接口設置IP地址 ip address ip-address mask
掩瑪(mask)用于識別IP地址中的網絡地址位數,IP地址(ip-address)和掩碼(mask)相與即得到網絡地址。
3. 使用可變長的子網掩碼
通過使用可變長的子網掩碼可以讓位于不同接口的同一網絡編號的網絡使用不同的掩碼,這樣可以節省IP地址,充分利用有效的IP地址空間。
如下圖所示:
Router1和Router2的E0端口均使用了C類地址192.1.0.0作為網絡地址,Router1的E0的網絡地址為192.1.0.128,掩碼為255.255.255.192, Router2的E0的網絡地址為192.1.0.64,掩碼為255.255.255.192,這樣就將一個C類網絡地址分配給了二個網,既劃分了二個子網,起到了節約地址的作用。
4. 使用網絡地址翻譯(NAT)
NAT(Network Address Translation)起到將內部私有地址翻譯成外部合法的全局地址的功能,它使得不具有合法IP地址的用戶可以通過NAT訪問到外部Internet.
當建立內部網的時候,建議使用以下地址組用于主機,這些地址是由Network Working Group(RFC 1918)保留用于私有網絡地址分配的.
l Class A:10.1.1.1 to 10.254.254.254
l Class B:172.16.1.1 to 172.31.254.254
l Class C:192.168.1.1 to 192.168.254.254
命令描述如下:
任務 命令
定義一個標準訪問列表 access-list access-list-number permit source [source-wildcard]
定義一個全局地址池 ip nat pool name start-ip end-ip {netmask netmask | prefix-length prefix-length} [type rotary]
建立動態地址翻譯 ip nat inside source {list {access-list-number | name} pool name [overload] | static local-ip global-ip}
指定內部和外部端口 ip nat {inside | outside}
如下圖所示,

路由器的Ethernet 0端口為inside端口,即此端口連接內部網絡,并且此端口所連接的網絡應該被翻譯,Serial 0端口為outside端口,其擁有合法IP地址(由NIC或服務提供商所分配的合法的IP地址),來自網絡10.1.1.0/24的主機將從IP地址池c2501中選擇一個地址作為自己的合法地址,經由Serial 0口訪問Internet。命令ip nat inside source list 2 pool c2501 overload中的參數overload,將允許多個內部地址使用相同的全局地址(一個合法IP地址,它是由NIC或服務提供商所分配的地址)。命令ip nat pool c2501 202.96.38.1 202.96.38.62 netmask 255.255.255.192定義了全局地址的范圍。
設置如下:
ip nat pool c2501 202.96.38.1 202.96.38.62 netmask 255.255.255.192
interface Ethernet 0
ip address 10.1.1.1 255.255.255.0
ip nat inside
!
interface Serial 0
ip address 202.200.10.5 255.255.255.252
ip nat outside
!
ip route 0.0.0.0 0.0.0.0 Serial 0
access-list 2 permit 10.0.0.0 0.0.0.255
! Dynamic NAT
!
ip nat inside source list 2 pool c2501 overload
line console 0
exec-timeout 0 0
!
line vty 0 4
end

六、配置靜態路由
通過配置靜態路由,用戶可以人為地指定對某一網絡訪問時所要經過的路徑,在網絡結構比較簡單,且一般到達某一網絡所經過的路徑唯一的情況下采用靜態路由。
任務 命令
建立靜態路由 ip route prefix mask {address | interface} [distance] [tag tag] [permanent]
Prefix :所要到達的目的網絡
mask :子網掩碼
address :下一個跳的IP地址,即相鄰路由器的端口地址。
interface :本地網絡接口
distance :管理距離(可選)
tag tag :tag值(可選)
permanent :指定此路由即使該端口關掉也不被移掉。

以下在Router1上設置了訪問192.1.0.64/26這個網下一跳地址為192.200.10.6,即當有目的地址屬于192.1.0.64/26的網絡范圍的數據報,應將其路由到地址為192.200.10.6的相鄰路由器。在Router3上設置了訪問192.1.0.128/26及192.200.10.4/30這二個網下一跳地址為192.1.0.65。由于在Router1上端口Serial 0地址為192.200.10.5,192.200.10.4/30這個網屬于直連的網,已經存在訪問192.200.10.4/30的路徑,所以不需要在Router1上添加靜態路由。
Router1:
ip route 192.1.0.64 255.255.255.192 192.200.10.6
Router3:
ip route 192.1.0.128 255.255.255.192 192.1.0.65
ip route 192.200.10.4 255.255.255.252 192.1.0.65
同時由于路由器Router3除了與路由器Router2相連外,不再與其他路由器相連,所以也可以為它賦予一條默認路由以代替以上的二條靜態路由,
ip route 0.0.0.0 0.0.0.0 192.1.0.65
即只要沒有在路由表里找到去特定目的地址的路徑,則數據均被路由到地址為192.1.0.65的相鄰路由器。
[責任編輯:佚名]
 相關文章
·避免“悲劇” 打印機使用技巧全面攻 (2010-1-26 14:17:03)
·挑選相紙有學問 教你如何辨別相紙優 (2009-11-13 17:21:28)
·精簡節約!小公司辦公打印省錢全攻略 (2009-11-13 17:19:26)
·如何提高噴墨打印機的性能 (2009-10-20 15:26:39)
·佳能墨盒打印頭維護常識一覽 (2009-10-20 15:26:00)
·非常實用來學習連續供墨系統入門知識 (2009-8-26 10:56:47)
·怕吃虧?怕假的?鑒別真假耗材的小竅門 (2009-8-26 10:55:25)
·價格更低?原裝耗材三大優點大匯集 (2009-8-26 10:53:50)
·老知識分享激光打印機典型故障維修 (2009-8-3 12:40:50)
·怎樣判別佳能打印機閃爍次數代表的故障類 (2009-8-3 12:39:15)
·維修經驗EPSON噴墨打印機維修談 (2009-8-3 12:36:16)
·維修經驗噴墨打印機常見故障與排除 (2009-8-3 12:34:43)
·內存引起的幾種故障 (2009-5-15 10:44:34)
·內存常見故障原因分析與排除法 (2009-5-15 10:43:50)
·在BIOS中優化內存的方法 (2009-5-15 10:43:17)
·虛擬內存常見問題的解決辦法 (2009-5-15 10:42:29)
·多內存混插問題解決方法 (2009-5-15 10:41:34)
·由內存引起的三種罕見故障 (2009-5-15 10:41:06)
·內存導致的BIOS的設置故障 (2009-5-15 10:40:36)
·內存六種異常故障及解決方法 (2009-5-15 10:40:03)
 熱門文章 哈爾濱電腦
·SQL Server到底需要使用哪些端口?
·安全防護策略-打造堡壘主機
·把重要的Word 2003文檔放到菜單中
·資深網管教你打造SSL加密的安全站點
·您試圖在此 Web 服務器上訪問的 
·還有2天發布 Windows7必備77條小知識
·Photoshop制作火焰的神龍
·Win2003架設多用戶隔離Ftp服務器
·XP系統服務恢復批處理
·Asp偽靜態的實現及URL重寫-用ISAPI_Rewrite實現
·情侶玩兒法:用虛擬硬盤打造堅不可摧的影子系統
 推薦文章 哈爾濱電腦
·精簡節約!小公司辦公打印省錢全攻略
·CSS布局方法的十八般技巧和兼容方案
·三種方法 教你解決輸入法不顯示的問題
·當紅情侶QQ表情:茉莉和龍井
·Win 7出現休眠Bug 微軟提供解決方案
·將Powerpoint文檔轉換為Word文檔
·非常實用來學習連續供墨系統入門知識
·怕吃虧?怕假的?鑒別真假耗材的小竅門
·情侶玩兒法:用虛擬硬盤打造堅不可摧的影子系統
·開始—運行(cmd)命令大全
·您試圖在此 Web 服務器上訪問的 
 最新文章 哈爾濱電腦
·Web服務器如何避免CC攻擊
·SQL Server到底需要使用哪些端口?
·XP系統服務恢復批處理
·局域網遭ARP攻擊網絡掉線批處理
·CISCO 2811 路由器配置命令全集
·避免“悲劇” 打印機使用技巧全面攻略
·保障遠程桌面Web連接安全四項注意
·教你六招處理服務器數據意外丟失
·挑選相紙有學問 教你如何辨別相紙優劣
·精簡節約!小公司辦公打印省錢全攻略
·CSS布局方法的十八般技巧和兼容方案
ag环亚平台app- ag环亚旗舰厅客户端下载